[筆記] 使用Bootstrap所碰到的套件相衝的問題

前言:

本篇是紀錄 六角學院 Vue一個電商網頁
課程中建置開發環境上所遇到的問題與解決方法

這個課程的前半段(基礎內容),都是可以直接使用線上編輯器 CodePen 完成課程中的題目。
到了使用Vue Cli建立網站的專案時,就開碰到套件相衝的問題...
我的開發環境:

Node.js v14.15.1
Npm 6.14.11
Vue Cli 4.5.11

對於剛接入前端的我...這部分就卡關卡好久...
這份課程是兩年前的,版本跟我目前用的差距有點大
課程範例是使用Bootstrap4.1.1
如果直接安裝Bootstrap 4.x 最新版,就會跟 sass-loader node-sass 這兩個套件相衝

最後解決的方法:

cd my projec
npm install --save axios vue-axios  
npm install --save bootstrap@4.1.1 
npm install --save jquery@3.5.1 popper.js@1.16.1 
npm install --save node-sass@4.14.1 sass-loader@7.3.1

Reference:

1.六角學院官網
2.Vue一個電商網頁 in Udemy
3.安装scss后报错Module build failed: TypeError: loaderContext.getResolve is not a function解决方法

Facebook Comments